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1 HELIOS WebShare Manager

1.1 Introduction

WebShare Manager adds web-based “drag & drop” workflow support and
file synchronization to HELIOS WebShare, the web-based file access and
management solution. Using any web browser, remote users can view server
content in HELIOSWebShare, and drag and drop files and folders between the
WebShare sharepoint and the desktop, with automatic two-way synchronization
of changes.

Remote workflows – with remote file management via drag and drop, remote
workflows are much easier because users can work in their preferred manner.
In a typical network environment, users can drag and drop files from network
volumes onto their local workstation hard disk. WebShare Manager adds
exactly this capability to WebShare web-based file access.

Remote project collaboration – is greatly facilitated because of the two-way
file synchronization. For example, while one user is designing a document,
another could be retouching the images at an entirely different site. When a
file on the server gets updated by another user your local copy automatically
gets updated as well. Or, when you make changes to your local copy, the
server version can get automatically updated. Automatic synchronization of
the content ensures that all parties are working with the same versions.

Note: WebShare Manager does work with older WebShare servers, thus you
will only need the latest WebShare Manager when logging on to different
WebShare server versions.
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Remote backups – another significant benefit of WebShare Manager file
synchronization is that it can automatically backup files from a workstation to
a remote WebShare server, allowing remote offices and laptops to be integrated
into your corporate backup system.

1.2 New WebShare Manager features

For new features in the WebShare Manager software see the HELIOS website:
www.helios.de Go to HELIOS Product Versions – New Features

For HELIOS Base, the foundation used by all HELIOS products, see the
HELIOS Base product web page:
www.helios.de Go to Products > Base

1.3 WebShare Manager installation

1.3.1 System requirements

See the client requirements for WebShare Manager in the HELIOS Base
manual, chapter 4.1.3 “Client requirements”.

1.3.2 Get WebShare Manager

Download via Internet

If the WebShare Manager application is available on one of your WebShare
sharepoints, download the appropriate version for your platform. Otherwise,
contact your WebShare administrator to request WebShare Manager.

https://www.helios.de/web/EN/products/new-features.html
https://www.helios.de/start.html?lang_id=en
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LAN connection – Windows

â Mount the “HELIOS Applications” volume, go to “Windows > WebShare
Tools” and double-click the “HELIOSWebShare Manager Setup.exe” icon.
Follow the instructions of the setup program.

Note: Use the Windows control panel “Add or Remove Programs” to uninstall older
versions of the “HELIOS WebShare Manager” tool.

LAN connection – OS X

â Open the network volume “HELIOS Applications”, go to “MacOS > Web-
Share Tools” and double-click the “HELIOS WebShare Manager” icon to
start the program, or copy it to your local “Applications” folder.

LAN connection – UNIX/Linux

â Copy “/usr/local/helios/public/Java/HELIOS WebShare Manager.jar” to a
UNIX/Linux workstation and enter the command:
# java -Xmx1024m -jar <path>/HELIOS\ WebShare\ Manager.jar

1.4 Create a project in WebShare Manager

Before WebShare Manager can manage project files, with the related down-
loads, uploads, and synchronization, it is necessary to create a project. You
may define a project either manually or have it done automatically.

1.4.1 What is a project?

AWebShare Manager project is simply a list of files (and optionally folders)
on a WebShare server, conveniently viewed in a single WebShare Manager
project window. It is in effect a “virtual directory” that can list files residing
in any sharepoint or directory on a WebShare server. This makes it easy to
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work with a group of files related to a project, even though the files might be
scattered in many directories on theWebShare server. For example, a project to
create a financial report might require spreadsheets, artwork, financial analyses,
document templates, etc. These would typically be saved to many different
directories on the server, but can conveniently be collected in a single project
list.

Each project consists of a list of files. Each file entry in the list is similar in
some respects to aWindows Shortcut, or a Mac Alias. But, there is a significant
difference, in that each file name in a project list actually references two files:
the version on the server, and a local copy.

Files from aWebShare server are added to a project by means of drag and drop,
or via the WebShare Manager “File Chooser”. These files are automatically
downloaded to the project folder (specified when creating the project) on your
local workstation. At the same time, the files are added to the file list in the
WebShare Manager project window. The project list shows the file name,
status, size, and modification date.

Note: On OS X and Windows you can move local files to any working directory
within the same volume. WebShare Manager recognizes the file ID and
volume ID, and hence preserves all links in a project.

Local files can also be added to a project, via drag and drop onto a file in
the project window. Since the file already exists on the local workstation it is
not copied into the local project folder. This can be verified in the Local File

path list in the project window (it may be necessary to activate the column as
described in 1.6 “Customize the WebShare Manager project list”). In addition,
local files added to a project are immediately uploaded to the WebShare server.

So once a project is created and files are added, there is always a copy on the
WebShare server and a copy on the local workstation. A project synchronize
plan (see 1.11.2 “Create or modify a synchronize plan”) can be configured so
that, when the file on the WebShare server gets updated by other users, the
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local file is updated as well. Or, the synchronization can work the other way
so that changes that you apply to a local file are updated to the copy on the
WebShare server.

1.4.2 Define a project automatically

If you drag and drop a file from the desired WebShare sharepoint into the
WebShare Manager main window, a “New Project” dialog window opens, with
all fields but the project name already filled-out (Fig. 1.1). If a project with
the same WebShare URL, the same WebShare File Server and the same user
already exists, this project is used and the file is added to it, even if it already
exists in another matching project. In that case, the file is not downloaded to
the project folder, instead the project entry is tagged with a link to the existing
local file. To cause the automatic creation of a new, different project, detach
any matching projects first (see 1.7.1 “Detach a project”). When defining a
project manually, this is not required (see 1.4.3 “Define a project manually”).

â State a project name and select the desired synchronize options.
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Fig. 1.1: Defining a project automatically

1.4.3 Define a project manually

â Start WebShare Manager and select Projects > New from the menu. Then
fill in the fields with the desired data.
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Project Directory is the location to which all downloaded files will be saved.
Files will be created with the same directory tree as in theWebShare sharepoint.

If the For Uploads, Backup Original Files option is checked, files that are
uploaded from the local project folder to the WebShare server do not overwrite
existing older files with the same name. Instead, the existing files are renamed
to “.sav”, “.sav1”, “.sav2”, and so on.

Fig. 1.2: Defining a project manually

After clicking OK, the project (“Pricelist_2017” in Fig. 1.2) has been created
and can be utilized.
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1.4.4 Define synchronization of directories

When synchronizing/downloading a whole directory from a WebShare share-
point into a WebShare Manager project, only the files currently within the
specified directory are downloaded into the local project, and subsequently
synchronized. However, if the Allow Directories As Project Files option has
been enabled, the directory itself is added to the project as a synchronization
object. When this is set, any new files added thereafter to that directory are
added to the project and synchronized.

If the While Adding A Directory, Search All Subdirectories is enabled, the
directory content is searched recursively, i.e. all subdirectories with their
content are also included in the synchronization/download.

WebShare Manager receives file names from the server in HELIOS-UTF8
encoding. By default it converts them to UTF8 on Mac clients, and preserves
HELIOS-UTF8 on Windows clients because Windows does not allow special
characters in file names.

1.5 Toolbar

The WebShare Manager toolbar contains the following items:

Choose a new file for upload/download

Open selected files in their default application

Open directories of selected files

Show enhanced info for selected files

Open “Log Window”
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Start upload immediately for selected files

Start download immediately for selected files

Stop selected file transfers and lock files

Refresh window and update synchronization status icons;
does no file synchronization

Start synchronization immediately, all other synchronization plan
settings apply as usual

Copy a URL list of the local copies of the selected project lines to
the clipboard

Paste URLs from the clipboard:

1. If it is a local project file (“*.wspro”) the project is attached

2. If it is a file on the WebShare server it is downloaded

3. If it is a local file it is uploaded to the server directory that
belongs to the project line

Remove selected files

Search for a string in local file names

Find last search string again

The toolbar can be toggled hidden and visible by use of the key shortcut
Ctrl+w+T (Mac: o+c+T). All toolbar icons have a counterpart in the menu.
The related function can be called via the shortcuts shown there.
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1.6 Customize the WebShare Manager project list

The WebShare Manager project list view can be customized according to your
needs (Fig. 1.3):

â Right-click on any column header.

â In the contextual menu select (or deselect) the items that should be available
(or hidden) in the project window.

Fig. 1.3: Customizing the project list view
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1.6.1 Project list column descriptions

Color Label Color label (used by Mac, WebShare, and “HELIOS Meta”
PCShare plug-in)

File File name on the server (can be modified locally)
Status File status – Get more information from the tooltip
Size File size (synchronized)
Date File modification date (synchronized)
Server Path Path to the file on the WebShare server
Local File Path to the local file
File ID Internal file ID (local, synchronized)
Comment File comment (synchronized)
Resize Columns Resize columns. Columns are resized to fit window

1.6.2 Rearrange columns

Show/hide columns Right-click on the column title.
Check the columns that should be displayed.

Rearrange column headings Click on a column title and drag it to new position.
Adjust column width Click and drag the vertical divider between column

headings.
Sort column Click on a column title to sort by that column, or to

reverse the sort.
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1.7 Manage projects and the project list

File management in the project list is done by selecting one or more files. A
right-click opens the contextual menu, which allows selecting items from the
File menu (Fig. 1.4). By setting the file status to “locked” (choose ), you can
exclude it from being synchronized.

Fig. 1.4: Opening the contextual menu

Selecting Get Info opens a window (Fig. 1.5) containing information about the
file status and path (both local and on the server), creation and modification
date. It allows setting, modifying and deleting color labels and comments.

The project list shows the synchronization status (see Fig. 1.3 and Fig. 1.4)
while the “Info” window (Fig. 1.5) shows the current local file compared to
the corresponding server file.

Comments that were modified via the WebShare Manager “Info” window are
displayed in the WebShare project list upon the next synchronization. Color
labels inherit the base color from the synchronization. A colorized arrow
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pointing upwards signalizes a local change, an arrow pointing downwards
indicates a change on the server.

If the file information window is opened for a folder, the Also Add New Subdi-

rectories option becomes available. This allows adding folders recursively.

Fig. 1.5: File information window

â To open a document with a particular application, drag it onto the program
icon of the application. To open the document with the specified standard
application, highlight it in the project window and click on the icon, or
simply double-click on the file name.

â Click on the icon to remove a file from a project. The referenced file on
the WebShare server is not deleted but the corresponding local file will be
deleted if you select Delete file and reference. Click on Remove reference

only (or hold down the w or o key while clicking on the icon) to make
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the file disappear from the WebShare Manager project window, however it
will remain in the project folder.

Important: Local files that are added to the project (via upload) are not copied to the
project folder. On confirming the deletion (“Delete file and reference”), the
local original files are deleted from the file system! In this case an additional
confirmation query is displayed.

1.7.1 Detach a project

When a project is detached, the project is no longer shown in WebShare Man-
ager, and the project files are no longer synchronized with the corresponding
files on the WebShare server. However, the local project files are not deleted,
they remain in the local project folder.

â To detach a project, select it in WebShare Manager and choose Projects >

Detach Project from the menu.

1.7.2 Attach a project

To attach an already defined project to WebShare Manager do the following:

â Open Projects > Attach Project. In the file browser open the respective
project folder and select “*.wspro”.

You may also to drag the “*.wspro” file directly from your local file manager
(e.g. Finder, Windows Explorer) onto the WebShare Manager project window.
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1.7.3 Delete a project

There are two ways to delete a project from WebShare Manager:

â If it is still running, quit WebShare Manager.

â Navigate to your user directory and open the “WSManager” folder.

â Delete the desired project folder from your computer.

Or, without the need to quit WebShare Manager first:

â Detach the desired project (Project > Detach Project).

â Navigate to your user directory and open the “WSManager” folder.

â Delete the desired project folder from your computer.

1.8 Download files and folders from a sharepoint
using WebShare Manager

There are two ways to download files or even whole folders from a WebShare
sharepoint to a WebShare Manager project:

â In the WebShare Manager project list, click on the icon, which opens
the “File Chooser”, displaying a list of sharepoints. Double-click any
sharepoint to show its directories. Select a file or folder from within the
desired sharepoint – or select the whole sharepoint – and click either
the OK button or the button (see Fig. 1.6). All selected items are then
downloaded into your WebShare Manager project.

â Alternatively, drag and drop them from the file chooser (see Fig. 1.6) or
the web browser into the WebShare Manager project list, but this means
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that the WebShare URL, the WebShare File Server and the user name for
source and destination must be identical.

If the current project is not suitable, WebShare Manager selects an appropriate,
already attached project. If no suitable project can be found it opens the “New
Project” window, allowing a new project to be defined. Or, if you wish to
add the files to an existing but unattached project, use File > Open Document

to select that project’s “.wspro” file. The “New Project” window will then be
filled in; click OK and the existing project will be reattached.

Fig. 1.6: Selecting the file “Cafeteria.tif” for download
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1.9 Upload local files to the WebShare server

There are two ways to select the target directory on the WebShare server:

â Click on the icon to open the “File Chooser” window and drag the local
files and/or folders that you wish to upload into the desired directory or
folder or sharepoint. Or, still being in the “File Chooser” window, click on
the icon, select the file or folder to upload from the “Upload to:” dialog
window and confirm your selection with the Upload button.

Note: If you are not connected to the WebShare server, a login dialog opens.

â Or, if any of the files have a server path that matches the desired upload
target directory, select the local files and/or folders that you wish to upload,
drag them into the WebShare Manager project window, and drop them
over a file with the desired server path. The files will then be uploaded
into that server path on the WebShare server.

Note: For this method you need not be connected to the WebShare server.

As soon as local files are added to a project, the upload process to theWebShare
server will start immediately. If the Reject Updates on option has been activated
(see 1.11.7 “Synchronize interval”), the upload will start after expiry of the
lock wait. The synchronize plan assigned to the project will then manage the
synchronization of file changes.

Note: Even if the synchronize plan does not synchronize uploads, local files can
be added to the project.
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1.9.1 WebShare Manager logging window

The log window (Fig. 1.7) is automatically opened if the program detects an
error situation. You can also open it manually:

â Go to File > Open Logging Window to open the “HELIOS WebShare Man-
ager Log” window.

Fig. 1.7: Logging window

Log levels:
Error Severe failure messages, e.g. programmatic errors
Warning Warnings, e.g. process interferences
Info Informative messages, e.g. project synchronization, file transfer
Verbose Progress messages, e.g. file synchronization
Extensive More detailed progress messages
Debug Provides debugging information (for experts only)

Logging settings can be specified in the Logging tab of the WebShare Manager
preferences. See section 1.12.4 “Logging”.
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1.10 Remote backups using WebShare Manager

WebShare Manager makes it easy to use a WebShare server as a remote backup
repository. Local files and folders can easily be backed up to the WebShare
File Server by adding them to a project (as described above). It makes sense
to configure a project or projects specifically for backup purposes, so that the
project settings and the synchronize plan can be set accordingly. For example,
to provide a “versioning” control, the option For Uploads, Backup Original

Files could be checked. The synchronize plan should be defined to synchronize
uploads.

Note that if the Allow Directories As Project Files option is switched off,
which is the default behavior, and you add a folder of files to the project, all
existing files in this folder will be added to the project list. Any new files
subsequently added to this folder will not be added to the list. To make such
additional files available in the project list, the folder must be dragged anew
onto the project window.

On the other hand, if the Allow Directories As Project Files option is acti-
vated, and you add a folder to a project, then this folder itself will be added to
the project as a synchronization object. Any new files that are subsequently
copied to this folder will be added to the project list.

Once the local files have been uploaded to the WebShare server, you can then
access them from any computer with internet access. This ensures that critical
files are preserved and available even in the case of loss or failure of the original
system or files.
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1.11 Synchronization

Each WebShare Manager project has a synchronize plan, which specifies
whether and how to synchronize changes between project files on theWebShare
server, and the corresponding local copies.

Various synchronize plans can be created or changed via the Settings > Syn-

chronize Plan menu. Each synchronize plan allows you to define the time
interval, days, and direction in which the content of the WebShare sharepoint,
and of the WebShare Manager project, is synchronized (see Fig. 1.8). Each
project can have its own synchronize plan, as selected when creating a project,
or via the Projects > Settings menu.

1.11.1 What gets synchronized?

• Only files listed in the project
• Data file and resource file
• Renamed server file updates the server file name in the project file list (but
the local file itself does not get not renamed!)
Renamed local file is not synchronized with server file name (but can be
viewed e.g. in File > Get Info)

• Creation date
• Modification date
• HELIOS file comment
• Color label

Note: By setting the status of a file to “locked” (click on the icon), you can exclude
it from being synchronized.
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1.11.2 Create or modify a synchronize plan

â From the Settings > Synchronize Plan menu select New to create a new
plan or select an existing plan you wish to modify. Projects that use this
synchronize plan are listed in Projects (Fig. 1.8).

Fig. 1.8: Synchronize Plan

1.11.3 Delete a synchronize plan

â Open the synchronize plan that you want to delete via Settings > Syn-

chronize Plan. Then select File > Delete from the menu and confirm the
deletion.
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Important: If a synchronize plan is currently in use, it cannot be deleted. The Delete
item in the File menu is then grayed-out!

Detached projects that had the deleted synchronize plan assigned will – if
re-attached – display the deleted plan’s name in red but follow the “Default”
synchronize plan unless an existing synchronize plan is assigned to the project.
The project window opens if the synchronize plan is missing upon project
activation.

1.11.4 Synchronize direction

The Allow Synchronize For options specify in which direction file changes get
synchronized. Note that only the files listed in the project list get synchronized.

Downloads

With the Downloads option checked for a synchronize plan, files on the Web-
Share server that have been modified will be downloaded during the next file
synchronization process, replacing the prior local version. That way when con-
tent on the WebShare server has been updated by other users, the synchronize
plan can update your local project content as well.

Note: To protect the local version of a file against being overwritten, it must be
copied to a backup folder. Moving the file is not sufficient becauseWebShare
Manager tolerates moving and renaming, and hence would overwrite the
file in the backup folder.

Files removed from the WebShare server will not affect the corresponding
files in the local project folder. If the project synchronize plan enables uploads
(Uploads option), then the local file will be uploaded to the WebShare server
during the next file synchronization process, to replace the missing file, and
keep them in sync.
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Note: Files added to the WebShare server (e.g. by other users) are only down-
loaded to the local project folder by the file synchronization process if the
folder is subject to synchronization (Allow Directories As Project Files
option. See also 1.10 “Remote backups using WebShare Manager”.

Uploads

The Uploads option is used to ensure that changes to the local copies of project
files get changed on the WebShare server as well. That way when you update
your local project content, the synchronize plan can update the corresponding
files on the WebShare server. Not only does this facilitate remote collaboration,
but it can also be used as a remote backup method.

Local copies of project files that have been modified will be uploaded to the
WebShare server during the next file synchronization process, replacing the
prior version there. If the project option For Uploads, Backup Original Files

is enabled, existing files are renamed to “.sav”, “.sav1”, “.sav2”, and so on
(see 1.4.3 “Define a project manually”).

Note: If the local copy of a project file is deleted, it will not affect the corresponding
file on the WebShare server. If the project synchronize plan enables down-
loads (Downloads option), then the corresponding file on the WebShare
server will be downloaded to the local project folder during the next file
synchronization process, to replace the missing file, and keep them in sync.

1.11.5 Synchronization status

The status of files in the project window is represented by icons. The following
table lists all available status icons and their meaning:

Server file is being downloaded to the project folder

Local file is in sync with that on the server
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Local file is missing

Local file is newer than that on the server

Local file is older than that on the server

Local file is locked and excluded from synchronization actions
(Used in combination with other upload or download status icons. Or, if
standalone, the local file is in sync but locked)

Local file and server file do not match, i.e. both have been modified. No
automatic synchronization possible; the user needs to synchronize the
file manually, by use of the / buttons (see 1.11.6 “Upload/Download
conflicts”)

Server file is missing

Removed file found in trash

Upload/download action is stopped (e.g. due to disconnected server)
(Only in combination with other upload or download status icons)

Local file is being uploaded to the server

Wait . . .
(Only used in combination with other status icons)

Note: These icons do not show the comments synchronization status. But the
“Info” window will show both versions if they do not match. If the color label of
a file on the server differs from that in the local project folder, non-matching
colors are indicated by use of small triangels in the color label.

1.11.6 Upload/Download conflicts

It can happen that a user modifies a file on the WebShare server, while another
user is also changing that file as a local project file. In this case automatic
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synchronization is switched off and you must decide manually which file
should be used, the local file or the one on the server. This is done by selecting
the or button in the toolbar of the project window.

Note: Likewise, if the Uploads and Downloads checkboxes are both enabled, and
a color label (or comment) of a file on the WebShare server is changed, and
there is a conflicting change to the corresponding local project file label (or
comment), then synchronization of the conflicting data will not occur. If you
wish to synchronize the conflicting label or comment, it must be manually
changed via WebShare, or the WebShare Manager “File > Get Info” window.

1.11.7 Synchronize interval

It makes sense to have different synchronize intervals for different projects. A
current project with many collaborators might call for a frequent synchroniza-
tion schedule (perhaps every few minutes), while other projects would need
less frequent synchronization (perhaps once a week). Of course, in addition to
the automated synchronize plan schedule for each project, a user can simply
click on the icon in the WebShare Manager toolbar to initiate that project’s
synchronize plan at once.

The Synchronize pop-up list (see Fig. 1.8) allows selecting a time interval in
minutes, or hourly, daily, or on a particular day of the week. In case of daily
or weekly synchronizations, the desired time can be specified.

â Choose Manually from the pop-up list if you do not want automatic syn-
chronization at all.

A click on the Advanced button reveals additional options to fine tune the
intervals. For example, if Synchronize is set to every day, but you want to skip
certain days and time ranges, e.g. from 01:00 to 02:30. The Use Default option
causes the Reject Updates on settings from the Default synchronize plan to
be used for the synchronize plan you are editing. That saves the trouble of
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entering these defaults for each synchronize plan. Uncheck Use Default to
specify custom settings for a synchronize plan.

1.11.8 Save and apply a synchronize plan

â When you have finished configuring a custom synchronize plan, click OK

to make it available in the Settings > Synchronize Plan menu.

It can then be applied to a project by clicking on the project name in the
WebShare Manager window, and then on the Projects > Settings menu. The
synchronize plan can be selected from the pop-up list.

1.11.9 Automatic synchronization

Project files are automatically synchronized according to the synchronize plan
specified for that project. If a synchronize plan cannot be performed when
scheduled, e.g. due to an interrupted internet connection, the files in the project
window will be synchronized with those on the WebShare server as soon as
the connection has been reestablished.

Note: When dragging and dropping folders from a server or the desktop into the
WebShare Manager project window, all files within the dragged folder will
be added to the upload/download synchronization. Files that have been
added subsequently to that folder are only downloaded to the local project
folder if the Allow Directories As Project Files option was activated
and the folder subject to synchronization was not deleted.
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1.11.10 Manual synchronization

â Click on the icon in the toolbar. The files on the specified WebShare
server will be synchronized with the WebShare Manager project files.

This is the way to synchronize a project if the synchronization interval is set
to Manually.

Note: When synchronizing manually, the defined sync interval is overruled, how-
ever the advanced options are taken into account.

â Click on the icon in the toolbar to download selected files.

â Click on the icon in the toolbar to start uploading previously selected
files immediately, regardless of the selected synchronize plan.

1.11.11 Download/Upload reconnect

In case a file transfer is aborted, e.g. internet disconnection, PC shutdown/
pause, all running transfers will be resumed with the next server reconnect. A
manually stopped transfer is resumed by clicking on the or button.

1.12 Preferences

Mac: “WebShare Manager > Preferences . . . ”

Windows: “Settings > Preferences”
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1.12.1 General

WebShare Manager Directory

Allows you to specify a default WebShare Manager directory, i.e. the path
to the project folder(s). Here, the single project folders and the log file (see
1.12.4 “Logging”) are stored (can be changed in the project management).

Size of Preview Images

This pop-up menu allows you to choose the preview image size used in the
“File Chooser” window (1.8 “Download files and folders from a sharepoint
using WebShare Manager”).

1.12.2 Proxy

Depending on your network configuration, you may use a proxy server to
connect to the WebShare File Server. The proxy configuration of WebShare
Manager should match your browser proxy configuration:

No Proxy

Use this option if no proxy server is used. This will likely be the case if you
are connecting to network internal WebShare servers only or if you are using
a DSL connection without the need for a proxy server.

Manual Proxy Configuration

HTTP Proxy

Specify the host name (or IP address) and the port number of your HTTP
proxy server.

SSL Proxy (HTTPS)

Specify the host name (or IP address) and the port number of your HTTPS
proxy server. This is only required if you are using an encrypted connec-
tion, and only if the HTTPS proxy server differs from the HTTP proxy
server.
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No Proxy for

This field allows specifying a proxy exception list for WebShare servers
that do not require a proxy server for being accessed (e.g. internal servers).
Separate multiple host names or IP addresses by a pipe character (“|”).
You may also use wildcards, e.g.:
server1.mycompany.com|server2.mycompany.com|*.subnet.mycompany.com

Here, advanced users can also use a regular expression (“Regex”).

PAC (Proxy Auto-Config) URL

Use this option if the proxy information is provided by a PAC file in your
network. Enter the full URL under which the PAC file is available, e.g.:
http://server.mycompany.com/proxy.pac

1.12.3 Security

The Security tab allows entering keys and passwords that are meant to improve
the WebShare Manager security. With the default settings, everything should
work “out-of-the-box”.

The CACerts File Password is a means of protection against a tampered CACerts
file, which is the system-wide Java keystore file. If a password is entered in this
field, WebShare Manager will only run if the password matches the password
stored in the CACerts file. If the password is left empty, CACerts is read
without any password check.

The actual file name of the CACerts file can be “jssecacerts” or “cacerts”, and
WebShare Manager looks for it in “<user.home>” (the home directory of the
logged-in user) and in “<java.home>/lib/security” (where “<java.home>” is
the Java runtime installation directory). The first file found will be used.

The CACerts file contains trusted certification entries that are used to verify the
server certificate for HTTPS/SSL connections. If no trusted certification entry
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is used (e.g. if the server uses a self-signed certificate), WebShare Manager
brings on a dialog (similar to most web browsers) requesting the user to allow
establishing the connection. If the certificate has not expired, the user has the
option to add it to the keystore, so that WebShare Manager will not request a
confirmation for this server anymore.

Trusted certification entries created byWebShare Manager are not stored in the
Java keystore file CACerts but in the “.wsmanager.keystore” file, where also the
saved passwords for establishing connections are stored. The saved passwords
are protected by a key (User Password Key field). The “.wsmanager.keystore”
file is, similar to CACerts, also password-protected as a whole (User KeyStore

Password field). If this field is empty, the CACerts file password is used. If this
field is also empty, the default password “changeit” is used.

All passwords specified in the Security tab are encrypted with some simple
algorithm and are stored in “.wsmanager.prefs”. Thus, anyone who has access
to “.wsmanager.prefs” and “.wsmanager.keystore” may theoretically retrieve
the saved passwords for the connections. By specifying a User KeyStore Path

the “.wsmanager.keystore” file can be saved to a path different from the user
home directory, e.g. on a USB stick.

1.12.4 Logging

The Logging tab allows specifying the logging behavior of WebShare Manager.
If Automatically open Logging Window for Warnings is checked, the “HELIOS
WebShare Manager Log” window will open if a warning message is issued by
WebShare Manager.

If it is desired to save all log records in a text file, Save Log records to file

“HELIOS WebShare Manager Log.txt” must be checked. The file is stored in the
“WebShare Manager” folder (see 1.12.1 “General”). The path is displayed in
the tooltip.
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The “Logging Detail” section allows you to specify which log level should be
applied:

m Normal

m Extended

m Debug Mode (May slow down your WebShare Manager)

The log levels are described in 1.9.1 “WebShare Manager logging window”.

1.12.5 Locale

The Locale tab allows choosing the WebShare Manager user interface language.
Currently supported are: English, French, German, and Japanese.

1.13 FAQ

m If I have upload synchronization enabled, how can I remove single files
from a project, without having them deleted from the server?
Just delete them in the WebShare Manager project window. The corre-
sponding local files in the project folder may be deleted if selected in the
upcoming window, which asks for confirmation of deletion.

m Is there a way to enable full download synchronization of a WebShare
server directory, so that any files added to that WebShare directory (e.g.
by another user) get added to a project?
Yes. Activate the Allow Directories As Project Files option (see 1.4.3 “De-
fine a project manually”) in the project settings and select then the desired
server directory for the download. It gets its own entry in the project
data list, which adds new files to the project upon manual or automatic
synchronization, or by clicking .
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m Upon launching WebShare Manager or attaching a project, a login window
is presented. If the login is canceled, the project list is shown, but in offline
mode (no status updates or synchronization). Is there a way to subsequently
login to bring the project online?
Yes. Click the File > New Up-/Download... menu or icon, which will open
a login window. After login, the file chooser window can be closed.

m Can I access and use the local project files directly (e.g. via the Mac Finder
or Windows Explorer) instead of via the WebShare Manager file list?
Yes. Open the directory of the selected file(s) via the button in the
toolbar.

m Can WebShare Manager be set up as a hidden process, so that the project
synchronize plans run as scheduled?
Working on aMac, you can close all windows while the scheduler continues
to run. On Windows and UNIX the log list installs in the taskbar as soon
as the last WebShare Manager window has been closed; only closing the
log window will quit the application. The menu item File > Open allows
opening the WebShare Manager main window anew.

m Can WebShare Manager be set up to launch automatically upon system
startup so that the project synchronize plans run as scheduled?
Windows:

â Drag WebShare Manager into the “Startup” folder.
Mac:

â Place WebShare Manager in the Dock and activate Open at Login.

m I get a “java.lang.OutOfMemoryError” if a project contains many thou-
sands of files. What can I do to avoid this?
By default, the maximum memory usage of WebShare Manager is limited
to 1024 MB. You can increase this value by starting the HELIOS Web-
Share Manager program with your own Java parameters (see your Java
documentation for details).
Increase the memory limit to 2048 MB with Oracle Java:
# java -Xmx2048m -jar "HELIOS WebShare Manager.jar"
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The example above applies to UNIX and when starting the WebShare
Manager program via command line on Mac or Windows. However, on
Mac and Windows, we recommend to modify the corresponding starter
programs to maintain client specific functionality of WebShare Manager.
Windows:

â Open the Windows Registry Editor (“regedit”).
â Open “HKEY_LOCAL_MACHINE > SOFTWARE > HELIOS Soft-

ware GmbH > HELIOS WebShare Manager” and double-click the
“VMOptions” entry.

â Edit the corresponding entry to the desired value, e.g. “-Xmx2048m”
and click OK.

Mac:

â Right-click on the “HELIOS WebShare Manager” program icon and
select Show Package Contents from the menu.

â Open “Contents > Info.plist” in a text editor, e.g. TextEdit, and locate
the “<key>VMOptions</key>” entry.

â Edit the corresponding entry to the desired value, e.g. “-Xmx2048m”
and save the document.

m File names including control characters show an unpredictable behavior
in WebShare Manager.
File names that include control characters (0x00 . . . 0x1F) are not sup-
ported, so affected files must be renamed.

1.13.1 Feedback welcome

We appreciate your feedback to improve WebShare Manager or this documen-
tation. Please use the feedback form on the HELIOS website:
www.helios.de/contact.html

http://www.helios.de/contact.html
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